Integration of the program with answerphone 1C

One of the major challenges of modern, large and small, businesses and companies is that all operational information on pricing, customer balance, stock, concentrated mostly in the same database. Often, each enterprise, this database has its own format and set in its own way, the needs of employees and for their convenience. It's really very easy, but just as long as there is no need to use information from the database in a third-party application or integrated with any software. At this stage there can be a variety of issues - from the difficulties in migrating to a complete incompatibility of formats.

However, in any growing company, this process of innovation and automation is inevitable. That is why more and more managers prefer solutions that are known to be compatible with already functioning in the company's systems and databases.

The most common version of workflow management and the client (or any other) database - it 1C. And, accordingly, in the first place, any new software should seamlessly integrate it with 1C.

Our software Call Office - is a telephone answering machine, and absolutely all of its features can be used from 1C. This means that you can make an automatic call-up of this group of clients or send sms-messages with arbitrary information to their contact list.

This is fairly easy, since the possibility of the software package 1C allows for external COM-object and call its functions directly, without having to switch out of the program. Respectively, and Call Office, being a full-COM-object that can be integrated with 1C to create services to alert your customers directly from a familiar interface.

Most importantly, in order to interact 1C Call Office is made possible not require huge effort. To ensure that you have seen this in the illustrative examples, below, we give an example of each of the functions of our program in the company, and how it will be called from 1C.

For example, if you want your system to ring up a list of contacts in the database yet 1C, and uttered a message to subscribers of any information from the same database, you only need to build into your program a few lines of code to connect to the Call Office

Example:

'VBscript example
Device = Новый COMОбъект ("CallOffice.Device");
Device.Open ();
Result = Device.Dial ("8987654321 - номер вашего телефона", 40);
Если Result = 0 Тогда
   Device.Say ("Нужно заплатить за интернет.wav");
КонецЕсли;
Device.HangUp ();
Device.Close ();

As well, the program can work as an answering machine. This is especially useful for companies involved in public service. If your database contains a list of telephone numbers of subscribers and the amount payable to each of them, then set up an automatic program and connecting it to your database, you can play each voice message to the caller with the amount of its debt.

Example:

'VBscript example
Device = Новый COMОбъект ("CallOffice.Device");
Device.Open ();
Result = Device.WaitForCall (-1);
Если Result = 0 Тогда
   Device.Say ("Ваша задолженость составляет");
КонецЕсли;
Device.HangUp ();
Device.Close ();

Another useful feature of the program is the sms-mailing. Information services with mailing sms messages are becoming more popular - their use and notification of new services, and as a reminder of the payment, and how information about the account, and for many other purposes. For example, if you want to notify their customers that paid period of service ends, the system must incorporate similar code.

Example:

'VBscript example
Device = Новый COMОбъект ("CallOffice.Device");
Device.Open ();
Result = Device.SendSMS ("8987654321 - номер вашего телефона", "Баланс вашего лицевого счета близок к нулю");
Если Result = 0 Тогда
   // Сообщение отправлено!
КонецЕсли;
Device.Close ();

Sms-answering machine function can be useful for those who regularly collects information from customers. Thus obtained sms message is stored in your database in the desired location, and eliminates the need to manually enter somewhere the information. For example, you can sms to accept orders from customers, sending them back an automated message that their order is accepted. They will immediately be entered into your database with the phone number from which the message was sent and the text sms, so that you can then contact the sender to clarify the details of the order.

Example:

'VBscript example
Device = Новый COMОбъект ("CallOffice.Device");
Device.Open ();
Result = Device.WaitForSMS (-1);
Если Result = 0 Тогда
   // какое-либо действие на компьютере
КонецЕсли;
Device.Close ();

As you can see, the program Call Office can do quite a variety of actions to inform your customers, adapting to the specifics of any company, and at the same time working directly from 1C. Application integration is quite simple, but the result of the output is quite impressive. Learn more about the features included in the Call Office and the possibility of purchase here.